800 phone number not connecting to Support team
Incident Report for Shadow Health
Resolved
Our 800 phone number is active again. This issue is resolved.
Posted 9 months ago. Oct 19, 2018 - 16:17 EDT
Investigating
We are aware of some issues with our phone provider and are working to restore service to our main number. For Student or Faculty Support, please call (352) 224-5012 or email us support@shadowhealth.com
Posted 9 months ago. Oct 19, 2018 - 14:31 EDT